Eye4Software Hydromagic

Hydrographic Survey Software


Download free demo version


Vessel shape and offsets

Using the built in "Vessel Editor" you can specify how the vessel should be drawn on the map.
It also allows you to set the exact location of the sensors, like transducer and GPS antenna.

The position of the sensors is used to calculate the offset between the GPS position and
the transducer position when the vessel's heading is known.


The vessel editor

To start the "Vessel Editor" utility, open the preferences dialog by selecting "Preferences..." from the "Options" menu.
In the preferences dialog, select the "Map" tab, and click the "Editor..." button as shown in the screen shot below:

Selecting vessel shape and offsets

The vessel editor will be started and will display the vessel as specified in the "File" field.
If no vessel file has been specified yet, it opens with a blank project.


Loading designs

Hydromagic is shipped with a couple of example vessel files.
To load one of these files into the vessel editor, select the "Open Design..." option from the "File" menu.
By default, all vessel designs are stored in the "C:\ProgramData\Hydromagic\Vessel" folder.

Loading a vessel design into the vessel designer utility


Creating a new design

To create a new design, just select "New Design" from the "File" menu.
If you have unsaved data, the application will prompt you to save it now.

After creating a new project, make sure you select the units for your new design first.
This can be done by clicking the currently selected units in the status bar, or by selecting the "Units..." option from the "Options" menu.

The best is to select the same units that are used in the drawing you have as reference.
In case you forgot to select the correct units, you can always convert all coordinates by using the "Scale Features" option.

Select working units for your vessel design


Grid options

To change grid options, select "Grid" from the "Options" menu.
Using the grid options, you can display a grid which can be used as guidance when placing objects.

The grid can also be used to snap objects to, both options can be enabled or disabled.

Vessel designer drawing grid options


Adding and modifying features

To add a line segment or polygon to the design, select "Draw Polyline" from the "Cursor" menu. To change the location of a single point, you can either drag the point around using the mouse, or alter the coordinates manually by right clicking the point, and select the "Edit Vertex..." option.

Modifying a single coordinate


Removing features

Existing segments can be modified by using drag and drop. To remove features from the design, right click on the shape in the "Object View" windows, and select "Remove Polyline". To remove a single point (vertex) from a line segment or polygon, right click the point and select the "Remove Vertex..." option from the context menu.


Moving features

In the vessel designer, features can be moved by entering the amount of units it has to move (shift) in the given directions.
To move features, click the "Move" button in the toolbar.

In the dialog box that appears, enter how many units the object has to move on the X and Y axes.

A negative value on the X axis means the object will be moved to the left.
A negative value on the Y axis means the object will be moved down.

Modifying a single coordinate


Scaling features

To scale the design by a specified amount, click the "Scale" button.
Alternatively, you can select the "Scale" option from the "Modify" menu.

In the dialog that appears, enter the scale factor. All coordinates will be multiplied with this value.

Entering a value greater then 1.0 increases the size of the design.
When entering a number smaller then 1.0 the size decreases.

This function can also be used to convert a design from, for instance, feet to meters.
In this example you would enter a scale factor of 0.3048.

Modifying a single coordinate


Mirror features

Objects can be mirrored horizontally or vertically by clicking one of the mirror buttons in the tool bar.
Alternatively, you can select these options from the "Modify" menu.

To undo a mirroring action, just perform the action again to restore the object to its current shape.


Rotate features

Using the rotate function you can rotate an object around its origin by any amount of degrees.
Objects can be rotated clockwise or counter clockwise.

To start the rotating tool, click either the "Rotate Left" or "Rotate Right" button in the tool bar.
Alternatively, you can select these options from the "Modify" menu.

Modifying a single coordinate


Setting sensor position offsets

You will notice two circles labeled "TXD", and "GPS". The "TXD" circle can be dragged onto the vessel to mark the location of the transducer,
the "GPS" circle is used to mark the location of the GPS antenna.

Instead of dragging the offset positions using the mouse, you can set them manually as well.
To do so, select the "Offsets" option from the "Modify" menu.

Setting sensor position offsets


Saving designs

After the design has been completed, and the GPS and transducer locations have been selected, you can save your design by selecting "Save Design..." from the "File" menu. Now you can close the "Vessel Editor" and select the design in the Hydromagic Survey software. When a valid GPS position is available, the ship will be drawn on the map using the specified vessel shape:

Vessel shape displayed on map